How to disable ?i=1 from your website

edited November 13 in News & Announcements

Many people here have asked for a way to disable ?i=1 or want to know how to disable it.
Well, I will tell you here how to do it:

How to disable ?i=1 Suffix

  1. Enable CloudFlare through Cpanel or transfer your domain to them
  2. (Optional) Enable the SSL use by selecting Full in the Crypto section

It should be disabled in 2-24 hours!

A logical explanation of why does that happen

First of all, when you enable CloudFlare through Cpanel a CNAME Record is added so that your domain points to:
yourdomain.com.cdn.cloudflare.net

That is very important, because that new domain is not hosted on ProFreeHost, so it doesn't have the ?i=1 suffix, and because of your domain pointing to there, your main domain also doesn't have it, it completely disables it until you disable CloudFlare.

This is also true on when you tranfer your domain to CloudFlare.

What next?

Now the ?i=1, alongside with some of its limits is gone.

Keep in mind that if you disable CloudFlare, it will be back.

If you don't want to use CloudFlare, you should upgrade to premium hosting.

There, you will have some other benefits also such as a free LE certificate, Railgun and so on.

Comments

  • edited November 13

    @ChrisPAR said:
    Many people here have asked for a way to disable ?i=1 or want to know how to disable it.
    Well, I will tell you here how to do it:

    How to disable ?i=1 Suffix


    1. Enable CloudFlare through Cpanel or transfer your domain to them
    2. (Optional) Enable the SSL use by selecting Full in the Crypto section

    It should be disabled in 2-24 hours!

    A logical explanation of why does that happen


    First of all, when you enable CloudFlare through Cpanel a CNAME Record is added so that your domain points to:
    yourdomain.com.cdn.cloudflare.net

    That is very important, because that new domain is not hosted on ProFreeHost, so it doesn't have the ?i=1 suffix, and because of your domain pointing to there, your main domain also doesn't have it, it completely disables it until you disable CloudFlare.

    This is also true on when you tranfer your domain to CloudFlare.

    What next?

    Now the ?i=1, alongside with some of its limits is gone.
    Keep in mind that if you disable CloudFlare, it will be back.

    If you don't want to use CloudFlare, you should upgrade to premium hosting.

    There, you will have some other benefits also such as a free LE certificate, Railgun and so on.

    I believe in Flexible and installing LE at server instead of FULL of Cloudflare because it can cause SSL Handshake error!

    Such Problem occurs when user remove it from PFH or uses Subdomain else like Blogger or Tumblr which causes that error.

    ↑ Edited by @ChrisPAR to add explanation given below by @ranakhas

  • edited November 13

    The exact opposite @ranakhas!
    Flexible can cause SSL Handshake error! Full is better!

    Wrong, did not know what SSL Handshake error is, thanks @ranakhas

  • @ChrisPAR said:
    The exact opposite @ranakhas!
    Flexible can cause SSL Handshake error! Full is better!

    I'm hoping you don't know about SSL Handshake Error it cause when Full or Struct SSL is chosen and no SSL is installed on Origin Server but good thing is that it can work with self-signed SSL too.

  • @ranakhas said:

    @ChrisPAR said:
    The exact opposite @ranakhas!
    Flexible can cause SSL Handshake error! Full is better!

    I'm hoping you don't know about SSL Handshake Error it cause when Full or Struct SSL is chosen and no SSL is installed on Origin Server but good thing is that it can work with self-signed SSL too.

    It doesn't matter here, there are self-signed SSL autoinstalled, so where is the problem?

  • @ChrisPAR said:

    @ranakhas said:

    @ChrisPAR said:
    The exact opposite @ranakhas!
    Flexible can cause SSL Handshake error! Full is better!

    I'm hoping you don't know about SSL Handshake Error it cause when Full or Struct SSL is chosen and no SSL is installed on Origin Server but good thing is that it can work with self-signed SSL too.

    It doesn't matter here, there are self-signed SSL autoinstalled, so where is the problem?

    Problem occurs when user remove it or uses Subdomain else like Blogger or Tumblr which causes that error

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion