SSL Private Key

edited December 2 in Support Forums

Hello,

I just noticed that I had installed a private key on my server while it's completely unneccesary, because all of the SSL stuff is being handled by CloudFlare. I can't seem to remove/uninstall it though. Whenever I clear the textbox, and hit upload, I get an error message saying that it can't be empty.

Any help?

EDIT: This also leads to my website giving a 404 error. You can check it for yourself here: https://www.webdesyners.gq/

Comments

  • edited December 2

    @XaafCode

    It would be helpful to find your domain in at least one post or you profile page activity XaafCode.

    I have not been able to delete Private Key, or CSR. The certificate can be deleted. Upgrade to premium I would hope gives you the function to delete Private Key, and CSR.

    You could use the ticket system an request they remove the key. That seems to be opposite of private key.

    I use my Let's Encrypt key. Being it is only the vpanel "domain name" that actually being encrypted, cloud flare seems like an extra hop.

    http;//www.badtech.gq/

  • @XaafCode said:
    Hello,

    I just noticed that I had installed a private key on my server while it's completely unneccesary, because all of the SSL stuff is being handled by CloudFlare. I can't seem to remove/uninstall it though. Whenever I clear the textbox, and hit upload, I get an error message saying that it can't be empty.

    Any help?

    EDIT: This also leads to my website giving a 404 error. You can check it for yourself here: https://www.webdesyners.gq/

    The Private Key does not mattter. As long as you have CloudFlare and have not selected the "Full Strict" Option on SSL Section it will be ignored.

    Also, I don't think this is the reason you get a 404. Are you sure that there is an index.html/index.php file in your htdocs folder?

  • edited December 2

    @XaafCode

    Thanks for adding the domain. With cloud flare remove the http to https redirect. Get the site reachable by http first then worry about SSL.

    You are also on unaux, which can be buggy.

    https://intodns.com/webdesyners.gq

  • Yes, there is an index.html file in the htdocs folder. I check that already. Also, on my other website I have been using the Full Strict option on CloudFlare, but I have not set the Private Key. It works fine there.

    I have tested it with other options, and right now I am using "Full" on https://www.webdesyners.gq/

  • Also, the SSL isn't working either anyways. (If you look it up in Chrome it doesn't have a closed padlock.)

  • @XaafCode said:
    I have tested it with other options, and right now I am using "Full" on https://www.webdesyners.gq/

    Full is correct. Please do what badbot said and disable HTTP to HTTPS redirect.

  • Ok, now it doesn't auto-redirect. It still shows that page though...

  • I had also downloaded the index.html to see if there was a fault in the code, but there is none....

  • edited December 2

    @XaafCode

    http://www.webdesyners.gq/ is not reachable.

    You are on unaux, which can be buggy. At this point using the panel support ticket system is an option.

    If it was me. I would remove cloud flare. Updating nameservers to ns1 and ns2.unaux.com and ns3 through ns5.byet.org.

    Then get the site reachable by http only.

    free sub domain
    If you are using a free sub domain, with addon domain. The file path is: /webdesyners.gq/htdocs

    Reminder
    DNS takes up to 72 hours to fully propagate. Most of the time just a few hours site will work.

    @Admin

  • Maybe this is the problem?
    https://imgur.com/2Mi4K1X

  • edited December 2

    Also, I have changed the nameservers to what you said to check if it has any effect @badbot

    EDIT: And I have uploaded a custom index.html to be sure that there are no fault in it.

  • Ok, this seems to work. Should I change it back to cloudflare now?

  • edited December 2

    @XaafCode

    Remove cloud flare To find webdesyners.gq's A record IP.

  • Go into vpanel look on right side panel for Main Domain "eeag.ezyro.com" or what ever yours is. do a reverse ip look up for "eeag.ezyro.com" then update your cloud flare with that IP.

    That would be easier then removing cloud flare.


    cloud flare two thumbs down.

  • Ok, well I just reconnected with CloudFlare and it doesn't give me the error anymore. The IP Adress was right already, so that wasn't an issue. I'll wait for a few hours to check if SSL starts working. Thanks for the help!

  • Ok, just checked. SSL is working fine now, and so is the website! :smiley:

  • edited December 2

    @XaafCode

    If you want to use www for the domain you will have to add "www A record" for it at cloud flare.

    cloud flare may have a way to just enable use www

    www, and webdesyners.gq's have the same IP for their A record.

    https://www.webdesyners.gq/

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!