Website displays error 524

Hi! I have recently created an account about a week ago with ProFreeHost, and I have registered my domain and configured the nameservers to host the site. I have also installed WordPress and a Cloudflare flexible SSL certificate, but when I go to my site, it often takes ages to load and often displays an error 524 message 'server failed to respond'. However, when I refresh the page, it often loads quickly with no errors. Is there a way to fix this issue, or is there an issue with the servers? You can have a look at my site by clicking on this link: https://ecommercey.cf .

Thank you ;)

Oscar

Comments

  • Also, it often displays an error 502 message too. Hopefully there is an easy fix to this, otherwise, I will migrate this site to another hosting provider.

  • I have found a reason for the error. I was able to get to the page just fine though:

    A 524 error states that Cloudflare was able to make a TCP connection to the origin, but the origin did not reply with a HTTP response before the connection timed out. Cloudflare will typically wait for a HTTP response from your server for 100 seconds.

    Seems like what ever you are using is a slow Script

  • @TheCrafters said:
    I have found a reason for the error. I was able to get to the page just fine though:

    A 524 error states that Cloudflare was able to make a TCP connection to the origin, but the origin did not reply with a HTTP response before the connection timed out. Cloudflare will typically wait for a HTTP response from your server for 100 seconds.

    Seems like what ever you are using is a slow Script

    I concur. Your account is working, you've just installed some heavy plugins on WP. Perhaps disable plugins sequentially to determine which are causing the issue, or find a WP alternative (there are quite a few ecommerce scripts available in Softaculous)

  • @humbletyrant said:

    @TheCrafters said:
    I have found a reason for the error. I was able to get to the page just fine though:

    A 524 error states that Cloudflare was able to make a TCP connection to the origin, but the origin did not reply with a HTTP response before the connection timed out. Cloudflare will typically wait for a HTTP response from your server for 100 seconds.

    Seems like what ever you are using is a slow Script

    I concur. Your account is working, you've just installed some heavy plugins on WP. Perhaps disable plugins sequentially to determine which are causing the issue, or find a WP alternative (there are quite a few ecommerce scripts available in Softaculous)

    He is using a ECommerce script, I checked. He is using WooCommerce.

  • @TheCrafters said:

    @humbletyrant said:

    @TheCrafters said:
    I have found a reason for the error. I was able to get to the page just fine though:

    A 524 error states that Cloudflare was able to make a TCP connection to the origin, but the origin did not reply with a HTTP response before the connection timed out. Cloudflare will typically wait for a HTTP response from your server for 100 seconds.

    Seems like what ever you are using is a slow Script

    I concur. Your account is working, you've just installed some heavy plugins on WP. Perhaps disable plugins sequentially to determine which are causing the issue, or find a WP alternative (there are quite a few ecommerce scripts available in Softaculous)

    He is using a ECommerce script, I checked. He is using WooCommerce.

    WooCommerce is a very heavy plugin. In addition, he could be using a heavy theme as well.
    A stand-alone ecommerce script, such as OpenCart may be a better solution.

  • Hi! I have recently created an account about a week ago with ProFreeHost, and I have registered my domain and configured the nameservers to host the site. I have also installed WordPress and a Cloudflare flexible SSL certificate, but when I go to my site, it often takes ages to load and often displays an error 524 message 'server failed to respond'. However, when I refresh the page, it often loads quickly with no errors. Is there a way to fix this issue, or is there an issue with the servers? You can have a look at my site by clicking on this link:
    https://shoptrip.ml

    Thank you ;)
    Afty
    Plzz Help Me!!

  • edited February 12

    @aftabchouhan52 said:
    Hi! I have recently created an account about a week ago with ProFreeHost, and I have registered my domain and configured the nameservers to host the site. I have also installed WordPress and a Cloudflare flexible SSL certificate, but when I go to my site, it often takes ages to load and often displays an error 524 message 'server failed to respond'. However, when I refresh the page, it often loads quickly with no errors. Is there a way to fix this issue, or is there an issue with the servers? You can have a look at my site by clicking on this link:
    https://shoptrip.ml

    Thank you ;)
    Afty
    Plzz Help Me!!

    This site points to another host. Please change your nameservers to the following ones:

    • ns1.byet.org
    • ns2.byet.org
    • ns3.byet.org
    • ns4.byet.org
    • ns5.byet.org

    After that, retry with CloudFlare.

Sign In or Register to comment.