Not receiving e-mails.

edited March 19 in Support Forums

Hello all.
I'm having quite a bit of an issue here: even after setting the MX record, I am still unable to receive e-mails, however, I am able to send them.

I have also tried changing the MX record to, but to no avail. I am using CloudFlare, and I am also using a custom domain (



  • edited March 19


    You used the cpanel to activate cloud flare. It will not work. Deactivat it, and sign up with cloud flare directly. The have a DNS manager that will allow you to add the mx records.

  • @badbot

    Okay, I disabled Cloud Flare and then I added my website manually through their website. I removed the MX record from my website and re-added it via Cloud Flare, but I am still not getting messages.

  • @Disreality

    Create an A record mx with the ip Change the mx record to:


    Wait for it to propagate.

  • Hello!
    It seems that I have received some older emails, although I am yet to receive some I sent today as a test.
    I did this in cloudflare:
    - Added an A record with name and the value the IP you gave me
    - Added an MX record with donau and the value

    Also, I have noticed recently that my subdomains are not working.

  • @Disreality

    The A record should be the same as the mx record.

    dc-2305e432e454 ->

    what do you mean not working. Mail? Cloud flare can only do the TLD domain. But then you could try an a record. for do

    sub -> what ever the IP is for, It may work.

  • It seems that I've received some e-mails I sent earlier again.
    I changed the MX record to point to
    I tried again, I think it actually just takes a bit of time before I get the e-mails, like a day or so. I'll keep you up to date.

    By subdomains I literally mean the subdomains. I had a subdomain for bugtracking,, and when I go to it now it simply fails (this site's IP address cannot be found). Tried making another subdomain, same issue.

  • I fixed the subdomain issue above by adding an A record in CloudFlare and guessing the last number of the IP lol

  • Nevermind, getting a 404 now.

  • I've got the mail working! Stupid me set the MX record name to instead of mx. Thank you so much :)

    However, I'm still having that issue with the subdomains.. :(

  • E-Mail stopped working again. Oh boy :(
    I have the following for mail in my DNS settings at the moment:

    A mx
    MX mx

  • edited March 24


    A -> mx ->
    MX ->

    Sub domain
    in cpanel find the main domain name it will be a sub. Something like I use to find the reverse ip domain check. ->

    That should be the sub domain IP. I do not think it will have encryption by cloudflare. It may not even work.

  • Hello!
    Thanks for helping me :)
    I did that, but both of them seem to be having the same issue still :(

  • @Disreality for your subdomain problem, can you try making your subdomain point to the main domain displayed in cPanel via CNAME?

    Example of main domain:

  • edited March 25


    Sounds good. If you paste the main domain in browser it redirects you to suspended page. cpanel software redirects to an account.

    If you add your subdomains to addon domains that may work. cpanel will know where to redirect too.

    same hosting account
    main domain: ->
    default domain: ->
    addon domain: ->

    Default domain is in addon domain. no way to get encryption!

    If you need encryption you must go

    That is the way true cpanel software works. the sub domain " would direct to a directory in named "sub". cname would make the url of directory look like but in reality

  • @ChrisPAR @badbot
    That seems to have fixed the subdomain issue! It seems to load just fine now. Thank you so much!

    E-Mail also seems to be working fine, too. I left the fix as it was last night, and this morning it seems good.

    Thank-You so much! You're the best.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!