Remove the "?i=1"

Hi, when i try to use an image from my website on freehost in another domain, the image displays an error because of the ?i=1 in the end of the address

here in this topic says:

This is the way we track stats of our clients' websites and unfortunately, it cannot be removed.

But theres anyway i can use php with file_get_contents() or anything else to display the image from another domain and still use the cookies to track?

Comments

  • @maath said:
    Hi, when i try to use an image from my website on freehost in another domain, the image displays an error because of the ?i=1 in the end of the address

    here in this topic says:

    This is the way we track stats of our clients' websites and unfortunately, it cannot be removed.

    But theres anyway i can use php with file_get_contents() or anything else to display the image from another domain and still use the cookies to track?

    https://profreehost.com/forum/discussion/715/how-to-disable-i-1-from-your-website

  • edited September 29

    @maath

    can you post your PFH domain.

    The tracking will not affect image tag:

    <img src="http://badtech.ezyro.com/images/7_100.png" />

    Hot linking is not allowed!

  • edited October 15

    [ method does not work ]

    You can use Apache rewrite to remove file extension, (?id=1) without blocking the tracking cookie.

    htaccess file

    #remove file extension
    RewriteEngine On
    RewriteBase /
    RewriteRule ^7_100.png/?$ 7_100.png  [NC]

    You may have to put a htaccess file in sub directory. (/images/)

    The img tag will now link to the image file at badtech.ezyro.com/images/7_100.png

    <img src="http://badtech.ezyro.com/images/7_100.png" />

  • @badbot said:
    You can use Apache rewrite to remove file extension, (?id=1) without blocking the tracking cookie.

    htaccess file

    #remove file extension
    RewriteEngine On
    RewriteBase /
    RewriteRule ^7_100.png/?$ 7_100.png  [NC]

    You may have to put a htaccess file in sub directory. (/images/)

    The img tag will now link to the image file at badtech.ezyro.com/images/7_100.png

    <img src="http://badtech.ezyro.com/images/7_100.png" />

    image

    @maath's problem was not the ?i=1 appearing, but the errors it created.

  • edited October 15

    @ChrisPAR

    It does not matter it does not work. can't hot link.

    <img src="http://badtech.ezyro.com/images/bg_foot.png" />

  • Use cloudflare

  • @humbletyrant

    That is helpful. you know anyway to link to an image on the PFH account domain besides using cloud flare?

  • @badbot said:
    @humbletyrant

    That is helpful. you know anyway to link to an image on the PFH account domain besides using cloud flare?

    You can link to locally hosted images. Or to an image hosting, such as ImgBB (like many people use in forums). I use cloudflare, because of its free SSL, and, I don't have i=1 parameter on my main domain, but, do on my sub-domains (as they are not using cloudflare). Of course, the tracking cookie still works (I believe it's for hits/CPU if I'm not mistaken).

  • edited October 5

    @humbletyrant

    so no you can not hot link.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!